MTH Networks - INCIDENT AFFECTING BROADBAND AND VOICE SERVICES ACROSS THE UK. – Incident details

INCIDENT AFFECTING BROADBAND AND VOICE SERVICES ACROSS THE UK.

Resolved
Major outage
Started over 1 year agoLasted about 23 hours

Affected

Openreach

Major outage from 12:15 PM to 8:13 AM

Updates
  • Resolved
    Resolved

    Please find an update from the Core Network below:

    No further impact is being seen currently. We continue to monitor the situation. Network teams are planning additional mitigating steps as future safeguard.

  • Monitoring
    Monitoring

    Please find an update from the Core Network below:

    We have seen traffic levels return to normal following mitigating actions by our networks teams. This situation is continuing to be investigated and monitored.

  • Identified
    Identified

    Please find an update from the Core Network below:

    Investigation and actions are still ongoing within our network teams to mitigate the amount of impact to the DNS from what is believed to be an attack of some form. No ETR is available at this time.

  • Investigating
    Investigating

    Our Core Network Partners are aware of a critical issue, similar to that experienced on 02/04/2024, seeing an impact to a vast array of connections across the UK. Their investigations are underway as we speak, of which are being handled with the utmost priority.

    Please find the latest information provided below:

    We have recently started seeing similar activity as was occurring on 02/04. This has been reported back to our network teams for further investigation. This has been kept open in the background as it is believed to be linked to a global DNS amplification attack being broadcast at multiple networks not inclusive to us.

    We anticipate another update to be provided within the hour, if not before.

    We apologise for any trouble and inconvenience caused here.