CityFibre Core Maintenance
Scheduled for May 21, 2025 at 11:01 PM – May 22, 2025 at 5:01 AM
Affects
CityFibre
Under maintenance from 11:01 PM to 5:01 AM
Completed
May 22, 2025 at 5:01 AMCompleted
May 22, 2025 at 5:01 AMMaintenance has completed successfully
In progress
May 21, 2025 at 11:01 PMIn progress
May 21, 2025 at 11:01 PMMaintenance is now in progress
Planned
May 21, 2025 at 11:01 PMPlanned
May 21, 2025 at 11:01 PMCityFibre are conducting planned maintenance on their network. Affecting Services to the below areas:
Brixworth
Cambridge
Christchurch
Coventry
Dundee
Ipswich
Kettering
Leicester
Portsmouth
Reading
Rothwell
Sheffield
Solihull
Stratford-upon-Avon
Swindon
Service Outage will be expected during the maintenance window.