MTH Networks - MS3 INCIDENT: DN16 & DN17 – Incident details

MS3 INCIDENT: DN16 & DN17

Resolved
Partial outage 5 %
Started 5 days agoLasted 2 days

Affected

MS3

Partial outage from 12:03 PM to 7:00 AM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Monitoring
    Monitoring

    Hi all,

    We are still awaiting official comments from MS3. However, we are seeing many restored connections. As soon as we have any updates to share, we will post them here.

    If you are still experiencing issues with your connection and would like us to take a deeper look, please email us at support@mthnetworks.com.

    Your joint patience and understanding is much appreciated.

    Kind regards,

    Your MTH Networks Team.

  • Investigating
    Investigating

    Good afternoon,

    We have been informed by MS3 Network of an ongoing service interruption affecting the DN16 and DN17 areas. The issue appears to be related to a power supply disruption, and MS3 is actively working with the regional power grid to resolve it.

    At this time, MS3 estimates that service will be restored within the next 3 hours.

    We sincerely apologise for the inconvenience this may cause and appreciate your patience as we work to resolve the issue as quickly as possible.

    Kind regards,

    Your MTH Networks Team.