MTH Networks - INCIDENT AFFECTING BROADBAND SERVICES: Newton Le Willows – Incident details

INCIDENT AFFECTING BROADBAND SERVICES: Newton Le Willows

Resolved
Partial outage
Started about 1 month agoLasted about 1 hour

Affected

Freedom Fibre

Partial outage from 4:30 PM to 5:28 PM

Updates
  • Resolved
    Resolved

    Freedom Fibre engineers have been able to locate the source of the issue where a resolution has been put in place to bring the affected services back online.

    If you do continue experience issues with the connection please reach out to our support team.

  • Investigating
    Investigating

    The Freedom Fibre Network have made us aware of an ongoing incident in the Newton Le Willows region.

    Freedom Fibre engineers are currently investigating this outage to find the root cause.

    Please do not reset your network equipment.

    We apologise on behalf of The Freedom Fibre Network for any inconvenience this may cause. We will continue to do everything within our power to get your services back up and running as soon as possible.

    Thank you for your patience and understanding.