MTH Networks - MS3 INCIDENT: HU4 – Incident details

MS3 INCIDENT: HU4

Resolved
Partial outage
Started 20 days agoLasted about 3 hours

Affected

MS3

Partial outage from 11:51 AM to 3:16 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Investigating
    Investigating

    MTH Networks are aware an ongoing incident in the HU4 region.

    Please do not reset your network equipment.

    We apologise on behalf of The MS3 Network for any inconvenience this may cause. We will continue to do everything within our power to get your services back up and running as soon as possible.

    Thank you for your patience and understanding.