MTH Networks - OFNL Incident: Telford, TF4 (ID:347062) – Incident details

OFNL Incident: Telford, TF4 (ID:347062)

Resolved
Operational
Started 19 days agoLasted about 16 hours

Affected

OFNL

Partial outage from 2:47 PM to 6:37 AM

Updates
  • Resolved
    Resolved

    Update (14 May 2025 07:37hrs)
    Work to restore service was completed at 16:09 on 13/05/2025. Services should now be working as expected. We will continue to monitor services to ensure they remain stable.

    We apologise again for the inconvenience caused and thank you for your patience throughout this issue.

  • Investigating
    Investigating

    We have a network incident in the Telford TF4 area affecting phone and internet services. OFNL are looking into this and will provide an update as soon as possible.