MTH Networks - MTH Networks Network issues – Incident details

MTH Networks Network issues

Resolved
Partial outage
Started about 2 months agoLasted about 23 hours

Affected

MS3

Partial outage from 9:56 AM to 9:00 AM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Update
    Update

    We have confidently been able to split this once-believed large-scale issue into 2 entirely separate cases.

    For information about the secondary issue, of which has seen an impact to services in the HU5 and HU6 regions, please see below:

    The above incident has since been resolved.

    We are, however, aware that the primary issue is still present. Our investigations are still ongoing, whereby we're doing all that we can to bring an expedited resolution to you all as soon as possible.

    We will keep you updated with any and all updates.

    Thank you for your patience.

  • Investigating
    Investigating

    We are aware of an issue that appears to be impacting the majority of homes supported under The MS3 Network. Investigations are being conducted by both MTH Networks and The MS3 Network as we speak, where we are treating this matter with the utmost importance.

    Thank you for your patience and understanding.