MTH Networks - INCIDENT AFFECTING BROADBAND AND VOICE SERVICES ACROSS THE UK. – Incident details

INCIDENT AFFECTING BROADBAND AND VOICE SERVICES ACROSS THE UK.

Resolved
Major outage
Started 5 months agoLasted about 5 hours

Affected

Openreach

Operational from 1:12 PM to 1:57 PM, Major outage from 1:57 PM to 2:57 PM, Partial outage from 2:57 PM to 5:44 PM

Vodafone

Operational from 1:12 PM to 5:44 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Monitoring
    Monitoring

    We are seeing services return to normal. We will monitor and provide a further update shortly.

  • Identified
    Identified

    Our upstream carriers networking team are continuing to work on resolving the issue.

    Please accept our sincerest apologies for the inconvenience caused. We will provide a further update by 15:30

  • Investigating
    Investigating

    Our Core Network Partners are aware of a critical issue, seeing an impact to a vast array of connections across the UK. Their investigations are underway as we speak, of which are being handled with the utmost priority.

    We apologise for any trouble and inconvenience caused here.