MTH Networks - Incident affecting Vodafone SoGEA connections – Incident details

Incident affecting Vodafone SoGEA connections

Identified
Major outage
Started about 2 hours ago

Affected

Vodafone

Major outage from 2:00 PM to 4:07 PM, Partial outage from 4:07 PM to 12:00 AM

Updates
  • Identified
    Identified

    We are seeing services restore. We will continue to monitor/advise.

  • Update
    Update

    We have not had any direct information from Vodafone. However, sources have suggested over 130,000 reports of Vodafone Outages across Broadband and Mobile connectivity. Hitting various News Channels also.


    As soon as any further information is released, we will advise further.

  • Investigating
    Investigating

    We are aware of a nationwide outage affecting Vodafone FTTC and FTTP connections.

    Updates will be provided as soon as they are available.